Enhancing your DAT Shopping Cart experience
Incident Report for DAT Freight & Analytics
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 10:23 CDT
Investigating
We are currently conducting scheduled maintenance on our shopping cart to enhance your experience. Please contact us at 1-800-547-5417 if you have any questions. We're experiencing longer than normal wait times, but we will get back to you as soon as possible.
Posted Mar 19, 2024 - 15:56 CDT
This incident affected: Tools & Services (Self Sign Up).