We are experiencing issues with our phone system
Incident Report for DAT Freight & Analytics
Resolved
This incident has been resolved.
Posted Nov 09, 2023 - 15:14 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 09, 2023 - 15:03 CST
Identified
We are currently experiencing a problem with our phone system and some customers are unable to hear the agent answering the call. We are working on the issue. In the meantime, you can reach us via email at customer.support@dat.com
Posted Nov 09, 2023 - 14:57 CST
Investigating
We are currently experiencing issues with our phone system. You can visit our help center or contact us by email at custsupport@dat.com
Posted Nov 09, 2023 - 14:53 CST
This incident affected: Tools & Services (Telephone Support).