Deleted loads continue to appear on the Load Board and search pages

Incident Report for DAT Freight & Analytics

Update

We are continuing to investigate this issue.
Posted Oct 21, 2025 - 10:58 CDT

Investigating

We are currently investigating an issue where deleted loads continue to appear on the Load Board and search pages. This is impacting compliance and operational visibility, with potential implications for fraudulent load detection. Our teams are actively working to resolve the problem as quickly as possible.
Posted Oct 21, 2025 - 10:53 CDT
This incident affects: DAT One Web.