Ratecast is unavailable in Rateview
Incident Report for DAT Freight & Analytics
Resolved
The Ratecast service is available in Rateview.
Posted Nov 17, 2022 - 09:10 CST
Investigating
We are currently experiencing an unexpected interruption of service. Engineers are working to restore service as soon as possible.
Posted Nov 17, 2022 - 08:41 CST
This incident affected: Freight Rates (Ratecast).